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1 INTRODUCTION

SAC-HOBI Tools is an Add-In for Microsoft Excel that loads, processes and
displays data from the in-situ hyperspectral radiometer/logging system custom-built for
SAC by HOBI Labs. Integration of these software functions into Excel provides a
simple, familiar GUI while providing direct access to Excel’s powerful analysis and
display capabilities. Further, it enables users to experiment with and modify the
algorithms used for deriving secondary parameters, using familiar Excel formulas.

1.1 System Overview

The system as a whole and its components are described in detail in the System
User’s Manual. Here we describe it briefly as it relates to this software.

The in-situ system consists of
e Four HydroRad radiometers measuring seven optical quantities:
o Downwelling surface irradiance (Eys)
o Subsurface downwelling irradiance at three depths (Ey;, Es2, Eq3)
o Subsurface upwelling radiance at three depths (L,;, L., and L,;3)
¢ A fluorometer measuring
o Chlorophyll fluorescence
o Turbidity
e A three-axis magnetic orientation sensor measuring
o Tilt
o Roll
o Magnetic heading

e A HydroDAS logger/controller that governs the operation of the sensors,
archives their raw data, processes the raw data, and sends processed data to its
console port for transmission to shore via satellite.

1.2 Data Processing Steps

Data from the system undergo three major stages of processing: raw data archiving,
primary processing, and derivation of secondary data, or post-processing. Archiving is
done only in-situ, by the HydroDAS. Primary processing is performed both in-situ and
by SAC-HOBI Tools. Post-processing is performed only by SAC-HOBI Tools.



1.2.1 Raw data archiving

Raw data are collected from individual instruments under the control of the
HydroDAS, and stored on its hard disk in one file per instrument, with the file name
extensions shown in the following table.

HydroDAS archives data into one file per instrument per day. The base name of
these daily files is the four-digit year, followed by the three-digit day number, of the date
on which the data were collected. For example, on the last day of 2006 the archive files
would be named 2006365.TLT, 2006365.FLR, 2006365.HR1, etc.

File name extension | File contents
JTLT Raw tilt, roll and compass data
FLR Raw fluorometer data
.HR1 Raw data from HydroRad #1 (measuring E;)
HR2 Raw data from HydroRad #2 (measuring E;; and L,,;)
.HR3 Raw data from HydroRad #2 (measuring £, and L,,)
.HR4 Raw data from HydroRad #2 (measuring E;; and L,3)

1.2.2 Primary Data Processing

Primary processing can be done both by the HydroDAS firmware, and by SAC-
HOBI Tools. It consists of the following steps:

e (alibrations are applied to raw HydroRad spectra, converting them to
radiometric units;

e Average and maximum tilt (and heading) are calculated for each spectrum;
e Spectra within the tilt limits are averaged together (time-averaged);

e Time-averaged spectra are spectrally averaged within user-specified
wavebands;
e Processed data are saved in a binary “.OUT” file;

e The file is transmitted to the console port.

When this processing is performed on the HydroDAS, the resulting binary .OUT
file is archived along with the raw data files, with the same base name as the raw files.
For example, the archived files for the last day of 2006 would include a file called
2006365.0UT that contains all the processed binary data generated on that day. SAC-
HOBI Tools can load, display, and post-process such files, as well as reprocessing raw
data sets. SAC-HOBI Tools does not generate .OUT files, but stores reprocessed data
directly into Excel workbooks in the same format as if they were loaded from .OUT files.



Primary processing in SAC-HOBI Tools is explained in section 4.2. Details of the
processed data files are explained in the System User’s Manual.

1.2.3 Secondary processing: Derived quantities

In addition to duplicating the processing capabilities of the HydroDAS firmware
(with some enhancements), SAC-HOBI Tools provides derivation of secondary quantities
from the primary processed data. These derived quantities are:

e Water-leaving radiance (L)

e Normalized water-leaving radiance (Lyw)

e Remote-sensing reflectance (R,y)

e Attenuation coefficients (K; and K,

e Chlorophyll concentration extracted from radiance

The algorithms for some of these, especially the normalized water-leaving radiance
and chlorophyll concentration, are the subject of ongoing research and debate. Therefore
we have designed SAC-HOBI Tools to permit SAC researchers to modify and
experiment with them within Excel. Details are explained in section 5.

1.3 Charting

In addition to loading and processing data as described above, SAC-HOBI Tools
provides tools for easy charting of both primary and derived data. Details are explained
in section 6.

1.4 SAC-HOBI Tools Files

SAC-HOBI Tools consists of two main parts:

e The add-in file “SAC-HOBI Tools.XLA”, which contains most of the
executable code, and

e The workbook template “SAC-HOBI Tools.XLT”, which contains pre-defined
worksheets and support code to hold the loaded and processed data. The setup
of this workbook is described in section 3.

A third file, “Install SAC-HOBI Tools.XLS” assists with installation (see section
2.3) but is not strictly required.



2 INSTALLATION

2.1 System Requirements

SAC-HOBI Tools requires a minimum of Excel 2002, Windows 2000, and a
Pentium II-class computer with sufficient resources to support Excel. The preferred
configuration is Excel 2003 or better, Windows XP or better, at least SOOMB of RAM,
and a clock speed of at least 1 GHz.

2.2 Security Settings

Because SAC-HOBI Tools contains executable programs that run within Excel,
Excel may present warnings or even disable some features, depending on its security
settings. To view and change Excel’s security settings, select Macro->Security... from the
Tools menu. We recommend a security setting of Medium. If the level is set above
Medium, you must use the Manual Installation procedure shown in section 2.4, and some
features may be disabled.

Security _\

Security Level | Trusted Publishers | Prior Trusted Sources

-

7 Wery High, Only macros installed in brusted locations will be allowed
ko run, All okher signed and unsigned macros are disabled,

i High. Only signed macros From trusted sources will be allowed ko
run, Unsigned macros are aukomatically disabled,

(ﬁ%ﬁdium. You can choose whether aor nok bo run pokentially unsafe
acras,

") Low {nok recommended), You are not protected From potentially
unsafe macros, [se this setting only if wou have wirus scanning
software installed, or you have checked the safety of all documents
woll apen.

[ (84 ] [ Cancel

2.3 Automatic Installation
This procedure requires Excel’s security level to be Medium or lower (see above).

First, copy the following files to a directory on your computer. If you later move
these files to a different directory, you will need to run the installation again.

e “SAC-HOBI Tools.xla”
e “SAC-HOBI Tools.xlt”



e “Install SAC-HOBI Tools.xlIs”

Double-click on the file “Install SAC-HOBI Tools.xIs”. If Excel displays a message
warning that the file contains macros, click Enable Macros:

-

Security Warning

"D\ Design ISRO Buoy! Software! Excel-YEA SAC-HOEBL Tools, xIt" conkains
Macros,

Macros may conkain viruses, It is usually safe to disable macros, but if the
macros are legitimate, wou might lose some Functionality.

[ Dizahle Macros ] | Enable Macros ,‘J [ Mare Info
L,

When asked if the file should be installed, click Yes.

A toolbar like the one shown below should then appear in the Excel window.

! S Load & Process Raw Files,.. [ Load Processed Files,, |:| Recalculate |Gl Create Chart.., ﬁ About SAC-HOEBL Toals.,, -

If the tool bar does not appear, pull down the View menu and look for the SAC-HOBI Tools
item. If it appears without a check mark next to it, select it and the toolbar should appear.

FruLeEcLn

Reviewing
Task Pane

Text To Speech
Yisual Basic
Wakch Window
Web

Wiardark

| 5AC-HOBI Tools %

Cuskomize. ..

2.4 Manual Installation

Use this procedure if your Excel security setting is too high to permit the automatic
procedure described above. Note however that a high security setting may also block
some features of the software, and of workbooks you create with the Add-In.

e Start Excel

e Select Macro->Security... from the Tools menu.

e On the “Trusted Publishers” tab (if it is present), select “Trust all installed add-
ins and templates”. Click OK.



rkéé urity

| Security Level | Trusted Publishers | Prior Trusted Sources

Issued To Issued By Expir... | Friendly Mame

VIEW FEMOYE

rust all installed add-ins and kernplates!
[ '"Frust access ko Yisual Basic Project

[ oK, l [ Cancel ]

e Select Add-ins... from the Tools menu. If this command is disabled and there are
no workbooks open in Excel, select New from the File menu, and open a blank
workbook. Then select Add-ins... from the Tools menu.

e Click Browse...

e Navigate to the directory containing the add-in files, and select the file “SAC-
HOBI Tools.xla”.

e Excel may ask whether you wish to copy the file to the Add-ins folder. Click
No.

-

Microsoft Excel

1 ) Copy ‘SAC-HOET Tools, xla' ko the Addins Folder #

Cancel

e The file you selected should now appear in the add-ins list, with a checkmark.
Click oK.

Yes




Add-Ins

-Ins available:

(=]
[l
=

Analvsis ToolPak,
Analvsis ToolPak - YBA&
Conditional Sum wWizard
Euro Currency Tools
Internet Assiskant YE&

CA= I

]
|[] Lookup wizard DHLASE
(|| Sac-Habi Taols T
Sokver Add-in utornation. ..

Sac-Hobi Tools

You should see a dialog announcing the presence of the Add-in, and its toolbar should
appear. If you do not see the tool bar, select Toolbars->SAC-HOBI Tools from the View menu.

2.5 Reversing Installation

Once you have installed the Add-In, it will automatically load every time you start
Excel, unless you move or rename the Add-In file. To uninstall the Add-in, open the
Add-Ins dialog box as described above, and uncheck Sac-Hobi Tools.

-10 -



3 WORKBOOK STRUCTURE

The template file “SAC-HOBI Tools.xIt” contains a number of worksheets set up
specifically for the HydroDAS data, as well a various features that are not visible to the
user but facilitate the handling of HydroDAS data. These include specially named cells
and ranges of cells, hidden cells and sheets, and executable code. Because of the
executable code, each time you open a file generated from this template Excel may
present a warning that it contains macros. It is safe to enable these macros.

The workbook template includes 20 predefined worksheets. These are divided into
categories indicated by the shading of their tabs at the bottom of the Excel window:

M Summary JEs /Ed1 fLul fEd2 /Lu2 fEd3 /Lus JFl 4 Params {Lw £ RSR { Kd12 f Kd23 fKd13 /Kul2 fKu2s ¢ Kuls fLow £ Chi,

Blue shading indicates information that summarizes or controls other sheets.
Yellow indicates primary data from individual instrument channels, and green indicates
data derived from the primary data.

3.1 Summary Sheet

The “Summary” sheet holds information about loaded data:

e A list of files from which data have been loaded, and the number of samples in
each (Figure 1). If the data were loaded from raw files, the “.OUT” file
extension is replaced with an asterisk (“*”).

e The serial numbers and channel identifications of the HydroRads whose data
have been loaded (Figure 2).

e The array of wavelength bands applied to the data.

These tables all filled in automatically during the loading process and should not
normally be changed by a user.

_File Samples | File Name
102 |2006001.QUT
102 (2006002, OUT
102 |2006003.0UT
102 2006004 OUT

Figure 1. File List

-11 -



Instrument Information

Serial No. | Channel | Units | CalFile |
_ HROS0142 | A-Ed | Wim'2/m | HROSO0T41CSY.
HROSO143 | A-Bd | Wim'dihm | HROS0143.C5Y |
HEOS0143 | B-Lu | WWmtdsrinm | HROS0143.C5Y |
HROSO14S | A-Bd | Wimtim | HROS0144.C5Y
HROSO145 | B-lu | Wim'Qisynm | HROS0144.CSY |
_ HROSO144 | A-BEd | Wim"nm | HROSO145.C5Y |
HROSO144 | B-Llu | Wim2isrnm | HROSD146.CSV |

Figure 2. Instrument List—yellow highlighting indicates a mismatch between the
calibration file and the instrument serial number.

3.2 Primary Data Sheets

The eight sheets with yellow-shaded tabs hold data loaded from the seven
HydroRad channels and the fluorometer, and are named accordingly. For example the
first sheet holds E; (surface irradiance) data, from HydroRad #1.

In all these sheets, each line of data represents one sample (with averaging applied,
if any). Each line starts with a sample sequence number, and the date and time the
sample were recorded, then various housekeeping data, then the primary spectral data for
the channel. Because Excel is limited to 255 columns in each worksheet and each
spectral band occupies one column, the number of spectral bands in each sample is
limited to about 230. SAC-HOBI Tools permits you to define as many bands as will fit
within Excel’s column limit. Excel can accommodate over 65,000 rows of data,
permitting display of very long time series.

3.3 Params Sheet

This worksheet holds various parameters that are used during calculation of the
derived data. These are described in further detail in section 5.

3.4 Derived Data Sheets

The 10 sheets with green-shaded tabs hold data derived from the primary data.
These are similar in format to the primary data sheets, with each line representing one
sample in time, and the spectral data presented with one column per spectral band.

Unlike the primary data sheets, these sheets also contain formulas that are used for
derivation of the secondary data. These are described further in section 5.

3.5 Modifying Workbooks

You are free to add any number of worksheets and charts to workbooks created by
SAC-HOBI Tools, and generally use all the normal Excel features to process and display.

-12 -



However you should avoid the following changes which could interfere with the
functions of SAC-HOBI Tools.

¢ Do not change the names of any of the predefined worksheets.

¢ Do not change the sequence of the predefined worksheets, or insert new sheets
between them.

e Do not delete or change the names of any named cells or formulas.

3.6 Modifying the Workbook Template

If you prefer to change the format of all new workbooks you create with SAC-
HOBI Tools, you can modify the template file (“SAC-HOBI Tools.xIt”). However you
should first create a backup copy of the file in case you accidentally make a change that
interferes with SAC-HOBI Tools functions. You must also obey the restrictions listed in
section 3.5.

-13 -



4 LOADING AND PROCESSING DATA

4.1 Loading Data Processed by the HydroDAS

[ Load Processed Files. ..

The Load Processed Files... command on the SAC-HOBI Tools toolbar loads files
containing binary packets generated by the HydroDAS’s processing firmware.

Suitable files may be received via the satellite transceiver or USB offload from the
HydroDAS’s hard disk. Files received via satellite may contain text messages and other
characters that are not part of the HydroDAS format, but the SAC-HOBI Tools will
ignore these and find any properly-formatted binary packets in the file.

The command first presents a standard Windows file selection dialog box. You
may select any number of files by using the control or shift keys in combination with the
mouse. When you the click OK, the program will scan each file for HydroDAS data
packets. The name of each file scanned, and the number of packets it contained, will be
listed on the summary sheet. Note that it is possible for you to select files of any type,
even those that do not actually contain appropriate data. In that case the file names will
still be listed, but their sample counts will be zero.

If a SAC-HOBI workbook is already open and active when you select files to load,
you will be presented with the option to either append the files to the open workbook, or
to create a new workbook from the template.

SAC-HOBI Tools

P Do wou wish to append data to the existing workbook, or create a
- ‘,/‘ new wiorkbook?

Append Tlew Cancel

If you choose to append data to an existing workbook, the spectral bands of the
data sets must exactly match each other. The software will check this and will not load
the data if the bands do not match.

-14-



4.2 Loading and Processing Raw Data

# Load & Process Raw Files. ..

The Load & Process Raw Files... command duplicates the processing performed by the
HydroDAS firmware, with a few enhancements. This command presents the dialog box

shown below, in which you set the following parameters:

e Spectral bands,

e Maximum tilt,

e HydroRad calibration files,

e Source files, and

e Destination.

Load & Process Raw Files

Spectral Bands

— Calculated Bands

[ Band | Center | width

First | 3s0

Last 850

Spacing IT

width | 10
Calculate =

From Workbook ==

— Mariual Band Eritry

Center 533
Wiclth 20
Add Band --=

From File...

Sawe to File...

1 350 10 4
2 360 10
3 370 10
4 380 10
5 300 10
& 400 10
7 410 10
! 420 10
g 430 10
10 440 10
11 450 10
12 460 10
12 47 10
14 480 i
15 400 10
16 500 10
17 510 10
1B sz 10
19 530 10
20 540 10
21 =0 10
22 560 10
23 50 10
24 580 10
25 50 10
26 600 10 ~|

Mazdrnurn Tilt

ES]E
Edi| 45 Lui | 45
Edz[ 45 Lz [ 45

Ed3| 45 La [ 45

Processing -

Select Files...

HR#4]DAS\CDntenBHCAL\HRDSD145.CSV o

| [ Frisac Test Data

2006228, *
2006229, *
2006230.*

Calibration Files

HR#1 ]DﬁS\CDntents\CAL\HRDSD142.CS\:’

HR#2 [Das\Contents\CAL\HROSO143.C5Y ...

HRL#3 ]DAS\Contentsu-:AL\HF{um144.Csv

Source Directary

— Destination

" append to SAC-HOBL ToolsS

Process | Close

4.2.1 Spectral Bands

Data are processed into the set of spectral bands you select in this dialog box.
Whereas the HydroDAS firmware is limited to a maximum of 50 bands, SAC-HOBI
Tools allows up to 230 bands (limited by the number of columns allowed by Excel). This
allows, for example, placing bands every 2 nm from 350 to 800 nm, or every 2.5 nm from
350 to 850 nm, for full hyperspectral analysis.

-15 -



To define the band set to be used, you can:

e Designate the first and last band centers, and a regular band spacing, then click
Calculate to produce a set of uniformly-spaced, constant-width bands;

e Click From Workbook to use the same band set as the currently active workbook
(this button is enabled only if a suitable workbook is active);

e Click From File... to load a band set from a file on your computer; or

e Enter an arbitrary set of bands one at a time, by entering the center wavelength
and band width, then clicking Add Band, for each.

To save the currently displayed set of bands to a file for later use, click Save to File...
To remove bands from the list, select them by clicking on them in the list (using the
mouse in conjunction with the control or shift key to select multiple bands), then click
Delete Selected Bands.

Note that if you wish to load new data into an existing workbook that already
contains data, the band sets must match. To ensure they match, click From Workbook to
load them from the existing workbook.

4.2.2 Maximum Tilt

You can enter a separate maximum tilt angle (in degrees) for each of the seven
radiometric measurement channels. Spectra collected when the buoy tilt exceeds their
corresponding maximum value will be excluded from the averaged output. To include all
spectra, set the maximum tilt to 45 or higher.

4.2.3 Calibration Files

Each of the four HydroRads requires a calibration file containing coefficients for
converting its raw data to radiometric units. You must ensure the calibration files are
assigned to the correct instruments. If the software detects a mismatch between the
instrument serial number and serial number stored in the calibration file, it will process
the data but set a quality control flag in the loaded data. For details about quality control
flags, see section 4.3.

4.2.4 Source Files and Directory

The Select Files... button presents a standard Windows open file dialog box, in which
you can select an arbitrary set of files to process (use the control and/or shift keys in
conjunction with the mouse to select multiple files). The files you select, and the
directory holding them, appear in the Processing section of the Load & Process dialog box.

-16 -



4.3 Viewing Data Worksheets

4.3.1 Missing Values

If no processed spectra are available from a particular sample, the cells
corresponding to that sample will be left blank and shaded gray. This may result from
transient problems, such as data transmission errors, or from normal events such high tilt
values that exclude all spectra from the averaged data. That is most likely at times when
light levels are low, leading to long integration times. This in turn results in fewer
spectra per sample, while also increasing the probability that an individual spectrum will
be influenced by buoy motion and excluded because of tilt.

4.3.2 QC Flags

Each of the primary data worksheets has a column for QC flags, and if any are set
they are highlighted as shown below.

Sample ; Spectrum| QC | Integ.
B Hate fins Count |Flags | Time
323 8M8/2006  9:06:29 1 High 4314
324 8A8/2006 9:09:23 2 High 3375
325 BA82006 112923 g 134

A “cal” flag will appear if instrument serial number does not match the serial
number in the calibration file used for processing it. Note that the instrument list on the
Summary worksheet will also highlight discrepancies between calibration file names and
instrument serial numbers (section 3.1).

The “high” flag will be set if an instrument’s peak spectral readings are higher than
another instrument at a shallower depth. Since the light level normally decrease at deeper
depths, readings that are consistently too high may indicate a malfunction in one of the
instruments, or a problem in the positioning of one of the light collectors. Occasional
momentary high signal levels may be triggered by normal phenomena such as wave
focusing.

-17 -



5 SECONDARY PROCESSING: CALCULATING
DERIVED PARAMETERS

J Recalculake

After the primary data worksheets are loaded with processed data, either directly
from HydroDAS files or processed from raw files, the secondary parameters are
automatically derived from them and placed in their own worksheets.

Some of these parameters are the subject of ongoing research, and will certainly
require fine-tuning as data are accumulated over the life of the system. In order to allow
SAC users to easily modify the algorithms used for this processing, they are expressed as
normal Excel formulas in the derived parameter spreadsheets. Some are also supported
by input parameters on the Params sheet.

We strongly recommend backing up the template file (“SAC-HOBI Tools.xIt”)
before making any changes to it.

5.1 Entering Algorithm Formulas

Each formula is entered in one key cell on the applicable spreadsheet of the
workbook template. During the calculation process (triggered either by the loading of
data, or by the Recalculate button), this formula is automatically copied throughout the full
range of cells to which it applies.

The cells holding the formulas are highlighted with yellow, and on most sheets are
in the column initially labeled “Spectral Data”. For example:

: % Load & Process Raw Files, . | Load Processed Files.,. || Recalculate ﬁ

02 - B =LwlD2/Esls2
A B [ ] E F
1 Sar:ple Date Time S%Ea[:;al
2 L #Dhvat 1
3
4
5

Here the value of the cell 1s “#DIV/0!”. This is normal in this case because no data have
been loaded. The formula for calculating Remote Sensing Reflectance, Rgs, is shown
above in the formula bar:

=Lw!D2/Es!S2

-18 -



Lw!D2 refers to the first cell containing spectral data on the Lw (water-leaving radiance)
sheet. Similarly, Es!S2 is the first spectral cell on the Es (downwelling surface
irradiance) sheet. This implements the definition of Remote Sensing Reflectance,

Res(h) = Ly(\) / E0", 1)

5.2 Entering Parameters

Some algorithms, particularly the normalized water-leaving radiance, are
sufficiently complex that, for convenience, their key parameters are entered separately
from the equations. These are gathered on the Params worksheet as shown below. Details
of this worksheet will be explained along with the individual parameters.

For Lyw Sun Angle calculation | For Ly Atmospheric correction |
Buoy Location Latitude Lungitude.TimeZnne A T(A) Toz(A)
Degrees o\ [ v | 55 W TP 2
Minutes 36 _ 17
For Ly,
water-air trans.: 1
index of refraction 1.34

For Chlorphyll and Turhidity from
Fluorometer

___Chl offset 92
Chl scale factor | 0.0123
__NTU offset | 70
MNTU scale factor | (0.006

_ For Chlorophyll Extraction from L |
Chl coeff A
Chl coeff B
Chl lambda 1
Chl lamhda 2

5.3 Initial Algorithms

5.3.1 Downwelling diffuse attenuation coefficients
Analytic equation:
Ki\)=I[Efz;, L) | Efz2, M)/ (22— z))
where z; is the depth of sensor i.

Since the system measures E (z, A) at three depths, (z;, z», z3), there will be three
computations of K, corresponding to the depth combinations (z;, z2), (z2, z3), (z1, z3). The
corresponding Excel equations are

=LN('Ed1'1S2/'Ed2'1S2)/('Ed2'1$N2-"Ed1"I$N2)
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=LN('Ed2'1S2/'Ed3'1S2)/('Ed3"$N2-'Ed2'1$N2)
=LN('Ed1'1S2/'Ed3'1S2)/('Ed2"1$N3-'Ed1'$N1)

Note that the references to column N on the Ed sheets, which holds the depth values, are
preceded by “$”, indicating absolute references. The other references are relative.

5.3.2 Upwelling radiance attenuation coefficients
Kp(h) =In[Ly(z1, X) / Lu(z2, V)] / (z2—z1)

Similarly to K;, we use measurements of L, at three depths to calculate three K,
values:

=LN(Lu1!S2/Lu2!S2)/(Lu2!$N2-Lull$N2)
=LN(Lu2!S2/Lu3!S2)/(Lu3!$N2-Lu2!$N2)
=LN(Lu1!S2/Lu3!S2)/(Lu3!$N2-Lull$N2)

5.3.3 Water leaving radiance, L,/(\)

To compute L,,, we must first propagate L,(z/) to the surface. To do this, we use
the computation of K, measured from L,(z,) and L,(z2). Hence, L, just below the surface
is estimated to be:

L,(07) = L,(z;) exp(KLu, z1)-
Then we propagate L,(07) through the air-water interface to obtain Ly:
L\ =L0) ¢/ n?

In Excel,
=Lul!S2*EXP(KIu12!D2*Lul!$N2)*water_air_transmission/(index_of_refraction)”2

The symbolic names “water air transmission” and “index of refraction” refer to values
entered in the appropriately labeled cells on the Params worksheet.

5.4 Remote sensing reflectance
Res(A) = LX)/ E0", 1)

In Excel,
=Lw!D2/Es!S2

5.5 Normalized water-leaving radiance
Ly,y(A) = L,y(A) exp{ [7(1)/2 + 1.(A)] [1/cosBy] } / cos)

where 6 is the solar elevation angle and t(A) and 7o,(A) are atmospheric transmission
parameters. This equation involves a number of supporting parameters.
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SAC-HOBI Tools includes a function called SunElevation, for computing the solar
elevation angle 6). Sunelevation takes date, time, latitude, longitude and time zone
arguments. The latitude, longitude and time zone are entered on the Params worksheet.
The latitude and longitude are entered in degrees and minutes. North latitudes are
entered as positive, South as negative. East longitudes are entered as positive and West
as negative. The time zone is entered as an offset, in hours, from Greenwich Mean Time.
India’s time zone is +5.5 hours by this measure. Symbolic names are assigned to these
parameters in the workbook template, and used in the following Excel equation for the
sun angle:

=SunElevation(B2,Latitude_Degrees+Latitude_Minutes/60,Longitude_Degrees+

Longitude_Minutes/60,Time_Zone)

The spectral quantities t(A) and to,(A) must also be entered in the Params sheet,
in the form of Excel equations. These equations must be entered in the yellow-
highlighted cells shown below.

_ For Ly, Atmospheric correction

AR REYON
)

As part of the secondary parameter derivation, this table will be expanded to include the
complete list of wave bands, with their wavelengths shown in the A column. The
formulas entered in the yellow cells will also be copied so as to complete the table of
T(A) and to,(A) values. In the delivered template, these cells hold simple formulas that
are strictly for illustration. These must be replaced with formulas that are valid for

Finally, these elements are brought together in the Lnw worksheet, using the
following Excel formula:
=Lw!D2*EXP((LOOKUP(E$1,Tau_r_table)/2+LOOKUP(E$1, Tau_0z_table))
*(1/C0S(D2)))/COS(D2)

where D2 contains the result of the SunElevation function, E$1 refers to the wavelength,
and the LOOKUP function is used to find the values of t(\) and 1¢,(A) corresponding to
the wavelength.

5.6 Chlorophyll concentration

Various empirical algorithms are used for extracting chlorophyll concentration
from ocean color data. We have implemented the following algorithm with the
expectation that SAC scientists will choose input parameters that are appropriate to their
deployment location, and possibly modify the equation.
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C=exp[ A+ B L,(M)/L,(\) ]

Some scientists prefer L,y instead of L,, in this formulation. The wavelengths, A; and A,
and the parameters 4 and B are entered in the Params worksheet. The Excel equation we
have entered in the Chl worksheet is
=EXP(chl_coeff_A+chl_coeff_B*OFFSET(Lw!D2,0,chl_lambda_1_band) /
OFFSET(Lw!D2,0,chl_lambda_2_band)).

-2



6 CHARTING DATA

@ Create Chart,.,

The Chart Data... button opens a dialog box in which you can select any of the
radiometer channels, and/or derived parameters to plot. Data can be plotted spectrally or
as time series.

6.1 Spectral Charts

To display spectra, select the Wavelength option for the X Axis. In this mode you
will only be able to select spectral quantities to chart, and the Wavelength Bands list will be
disabled because the entire spectrum will be displayed. You can select any number of
parameters to display within one chart. Of course since they will share one set of axes,
some combinations of parameters will not be useful.

Chart HydroDaS Data
X dxis | [ Spectral Data
* wavelength Channels Wavelenath Bands
" Date & Time Es 350 -
Edl 360
" Time of Day Lul 270
Edz 380
§ Lz 390
MNon-Spectral Data Ed3 400

Chl_Fl
Chl_L
Turhidity

410
420
430
440
450
460
470
480
490

so0 |

Make Chart | Caricel |

After you click Make Chart, the chart will display one spectrum of each of the
parameters you select. The spectra represent one sample from the data time series.
Below the chart, a horizontal scroll bar allows you to select which sample to display, or
to scan through all the time samples in the dataset. The sample number and time of the
currently-displayed sample are shown in the chart legend.

By default, the maximum of the Y axis automatically adjusts to the largest
spectrum displayed, and the minimum is fixed at zero. However while scanning through
a large data set with the scroll bar it is useful to be able to freely change between
automatic and fixed scaling. While you can change the settings through the normal Excel
functions, for more rapid control we provide a set of buttons in the upper left corner of
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spectral plots. In case the buttons interfere with the graph contents, they can be hidden
by unchecking Show Buttons above the chart area.

Show Buktons Show Buttons
0.05 0.05
Hold hax

Ao Ma

0.045 et Wi [ 0,045 -

Hald hin

hdin = 0

0.04 \/\ 0.04 \/\\

Hold Max fixes the maximum at its current value.

Ji

Auto Max sets the maximum to automatic (default setting)
Auto Min sets the minimum to automatic

Hold Min fixes the minimum at its current value

Min = 0 fixes the minimum at zero (default setting)

The default settings can be changed in the chart template (see section 6.4).

6.2 Time-series Charts

Chart HydroDaS Data
X dxis | [ Spectral Data
€ wavelength Channels Wavelenath Bands
(* Date & Time Es 350 -
Edl 360
" Time of Day Lul 270
Edz 380
Lu2 390
MNon-Spectral Data Ed3 %00
Chi_Fl Lu3 410
Chi_L L 420
Turbidi% RSR 430
Kdi2 440
kdz23 430
Kd1z 460
Klui2 470
Klu23 420
Kiu13
Livwr

Make Chart | Caricel |

To display time series, select the Time of Day or Date & Time option. In Date & Time
mode, the X axis will display the date. In Time of Day mode, the x-axis will have a 24-
hour range and if the dataset includes multiple days of data, the days will be overlaid.
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Time-series charts display the parameters you select throughout the entire time
range loaded in the present workbook. They do not include the scroll bar or axis-scaling
buttons of the spectral charts (because they are not needed).

6.3 Modifying Charts

After creating a chart in SAC-HOBI Tools you can use the full capabilities of Excel
to modify its format, rename it, add or remove data, or delete the chart.

6.4 Chart Template

The charts generated by this command are based on a template that is normally
hidden within the workbook. To modify the default settings that will be used for future
charts, for example the font styles of the axes or the position of the legend, you can
modify this template. However before making any changes you should make a backup
copy. To save a copy with the existing workbook template,

Open “SAC-HOBI Tools.xIt”
If the ChartTemplate tab is visible, click it to activate the template.
If the ChartTemplate tab is not visible,

o On the Format menu select Sheet->Unhide...

o Select ChartTemplate in the Unhide dialog box, and click OK.

o Click on the ChartTemplate tab in the workbook

On the Edit menu, select Move or Copy Sheet...

In the Move or Copy dialog box:

[ =

Move or Copy

Move selected sheets
To ook
| SAC-HOBI Tools.xt %]

Before sheet;

Kz |~
(K13 =1
| L
| Chi
| ChartTemplate =t
[(move ko end) |

Create a copy

o select (move to end) under Before sheet
o check Create a copy
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o click OK

This will create a new chart called “ChartTemplate (2)” which will serve as your backup.
To restore this as the main template, change its name back to “ChartTemplate”. To
change the name, right-click on its workbook tab, then select Rename from the popup
menu.
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